
Case Study 5: Langevin Transducer 
 
 
PROBLEM – Langevin Transducer , 2D Axisymmetric with ½ portion, PZT 8 
(50mm x 1mm Thick) sandwiched between Steel blocks (50mm x 19mm thick), 
Fluid is Water.   
 
 
GOAL  
 
The first example using 2D axisymmetry with a simple underwater transducer of the Langevin type. The 
example will use a small sample with a low frequency application and allow the visualization of 
underwater sound propagation.  The size of the Piezo is 50mm diameter x 1mm thick sandwiched 
between two steel blocks 50mm Diameter x 19mm thick. The piezoelectric disk is made of PZT8 material. 
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Figure C5.1. (Left) Detail of the Langevin Transducer; (Center) Transducer immersed in water; (Right) 

2D View of the transducer immersed in water. We will simulate one quarter of the 2D model 
 

 
Dia = 50 mm 
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 GEOMETRY/DRAWING 
 

1. Start GiD  or   
 
Although applicable for most versions of GiD and Atila this example will use GiD 11 and Atila 3.0.27. 
This example shows the used of Icons Toolbar in the illustrations. The Drop Down Menus will produce 
the same results. We will show the differences between using ATILA 6.0.0.7 (interface 2.0.2.5.4) and 
ATILA++ (interface 3.0.27).  
 
2. Create Geometry and Surfaces  
 
We will use 2D axisymmetry to simulate this problem in addition to mirror symmetry. This means that 
we will simulate only ONE QUARTER of the 2D model.  
 
Note: The axis of axi-symmetry for ATILA 6.0.0.7/2.0.2.5.4 is the X axis. However, for ATILA 3.0.27 
the axis of axi-symmetry is the Y axis. Consequently, the model representation will be different in 
ATILA 6.0.0.7 compared to ATILA ++. For clarity, we are adding the symbol of revolution in the 
associated axis for both the ATILA 6.0.0.7 and ATILA ++ cases.  
 
2.1 Create the Rectangle 
 
ATILA 3.0.27 

Click ( ) → ( ) →  Enter first corner point  → 0,0 → Enter second corner point → 25,20 → 
Enter 
 
ATILA 2.0.2.5.4 

Click ( ) → ( ) →  Enter first corner point  → 0,0 → Enter second corner point → 20,25 → 
Enter 

 
The Rectangle has been created as seen in Figure C5.2. Note that the object lines are shown in blue. GiD 
automatically creates the surfaces, shown in magenta. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.2. Rectangle creation. 
 



2.2 Divide the surface  
 
ATILA 2.0.2.5.4 

Click  Geometry  → Edit → Divide →  Surfaces → Near Point → Select Surface → Choose 
Nurbs Sense (V) → Enter Coordinates → 1,0 → Enter.  
 
ATILA 3.0.27 

Click  Geometry  → Edit → Divide →  Surfaces → Near Point → Select Surface → Choose 
Nurbs Sense (U) → Enter Coordinates 1,0 → Enter.  
 
The results are shown in Figure C5.3 left panel 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

 
Figure C5.3. Surface divided at 1mm thickness.  

 
2.3 Construct the Arc to create the Water Area 
 
The simulation of underwater operation requires the creation of the water area and assigning the material 
and boundary conditions to the defined area. The water will be simulated by a sphere of water having a 
radius of 80mm. Later on, we will apply the condition of radiating boundary to the surface of the fluid. 
The sphere of water will be represented in 2D by a quarter segment of a circumference.  
 
First of all, we will draw the arc of the 2D water surface. The arc is draw using three points. 
 
ATILA 2.0.2.5.4 

Click  ( )  → Enter First Point 0,80 → Enter → Enter Second Point 80,0 → Enter  →  Enter Third 
Point 0,-80 → Enter   
 
ATILA 3.0.27 

Click  ( )  → Enter First Point 80,0 → Enter → Enter Second Point 0,80 → Enter  →  Enter Third 
Point -80,0 → Enter   
 
The result is shown in Figure C5.4  left panel 



 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.4. Arc Drawn using three points of the circunference. 
 
2.4 Divide the Arc 
 
Next, we divide the circumference by half. We are interested in only one quarter. The result is shown in 
Figure C5.4. 
 
ATILA2.0.2.5.4 / 3.0.27 

Click  ( )  → Enter Number of divisions 2 → Select line to divide (Arc) → One line divided → OK  
  

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.5. Arc Divided in two parts.  



 
2.5 Delete the unneeded section 
 
Next, we remove the portion of the arc that is not required. The result is shown in Figure C5.6. 
 
ATILA2.0.2.5.4 / 3.0.27 

Click  ( )  → ( )→ Select the left (bottom) side of the Arc → ESC  
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.6. Unneeded section deleted 
 
 2.6 Draw the connecting lines 
 
Next, we connect the draw the two connecting lines to close the water surface. The result is shown in 
Figure C5.7. 
 

Click  ( )  → Control + A → Select the left end point of the Arc → Select the upper left corner of 
the box → ESC → Select the right end point of the Arc → Select the lower right corner of the 
narrow rectangle → ESC → ESC.  
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

 
Figure C5.7. Connecting lines to form the 2D water sector. 



2.7 Divide the Arc to construct the segments 
 
In order to simplify the meshing in the Water area and allow structured mesh, we will divide the water arc 
in three segments. The results are shown in Figure C5.8. 
 

Click  ( )  → Enter Number of divisions 3 → Select line to divide (Arc) → One line divided → OK   
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.8. Connecting lines to form the 2D water sector. 
 
2.8 Create the Arc segments by adding the connecting lines. 
 
The new created points in the water arc are joined to the points of the transducer as shown in Figure C5.9. 
 
ATILA 2.0.2.5.4 

Click  ( )  → Control + A → Select the left middle point of the Arc → Select the upper right 
corner of the narrow rectangle → ESC → Select the right middle point of the Arc → Select the 
upper right corner of the large rectangle → ESC → ESC.  
 
ATILA 3.0.27 

Click  ( )  → Control + A → Select the left middle point of the Arc → Select the upper right 
corner of the large rectangle → ESC → Select the right middle point of the Arc → Select the upper 
right corner of the narrow rectangle → ESC → ESC.  
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

 
Figure C5.9. Arc segments created. 



2.9 Create surfaces for Arc segments  
 
Click Geometry  → Create  → Nurbs Surface → Automatic → Number of lines (4) → OK → Cancel 
or ( ). The result is shown in Figure C5.10. 
 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.10. Surfaces Created. 
 
MATERIALS ASSIGNMENT 
 
3. Materials Assignment 
 
The material assignment can be done though the drop-down menu as shown in Figure C5.11. For this 
example, we will need Elastic, to assign properties to the steel, Piezoelectric, to assign properties to the 
piezoelectric discs and Fluid, to assign the properties to the water. The material assignment can also be 
done through the vertical icon toolbar as will be done in this example.  
 

 
Figure C5.11. -Drop-down Menu 

 
 



 

3.1 Assign Piezoelectric Material  
 

Click ( ) → PZT8 → Assign by Surfaces  → Select Surfaces →Finish or Esc.  
Click Draw → PZT4 to confirm the material has been added. Click Finish or ESC to quit. See Figure 
C5.12. for an illustration of confirmation of piezoelectric material assignment. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.12. Surfaces Created. 
 

3.2 Assign Elastic Materials   
 

Click ( ) → Select Elastic → Steel 1 → Assign by Surfaces  → Select Surfaces →Finish or Esc.  
 
Click Draw → All Materials  
Click Finish or ESC to quit. See Figure C5.13. for confirmation of material assignment. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.13. Elastic Material Confirmation 
 
 



3.3 Assign Fluid Materials  
 

Click ( ) → Select Fluid → Water → Assign by Surfaces  → Select Surfaces →Finish or Esc.  
Click Draw → All Materials  
Click Finish or ESC. See Figure C5.14. for confirmation of fluid assignment. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.14. Fluid Assignment Confirmation 
 

BOUNDARY CONDITIONS   
 
4. Boundary Conditions Assignment 
 
4.1 Polarization 
 
ATILA 2.0.2.5.4 
 

Click ( ) → Select Polarization → Select Cartesian → Select Define Local Axis→ Enter P1 → 
Select 3 Point XZ → Enter Center 0,0,0 → Enter Positive X 0,1,0 → Enter Positive Z 0,1,0 → Assign 
→ Select the surface of the piezo →  Finish or Esc.  
Click Draw → Polarization → Include Local Axis 
Click Finish or ESC.  
 
ATILA 3.0.27 
 

Click ( ) → Select Polarization → Select Cartesian → Select Define Local Axis→ Enter P1 → 
Select 3 Point XZ → Enter Center 0,0,0 → Enter Positive X 1,0,0 → Enter Positive Z 1,0,0 → Assign 
→ Select the surface of the piezo →  Finish or Esc.  
Click Draw → Polarization → Include Local Axis 
Click Finish or ESC.  
 
See Figure C5.15 for confirmation of Polarization assignment. 
 



ATILA 2.0.2.5.4 ATILA 3.0.27 

 

Figure C5.15. Polarization Confirmation 
 
4.2 Electrical Potential 
 
ATILA 2.0.2.5.4 
 

Click ( )  → Select Electrical Potential → Select Forced → Enter Amplitude 1.0  → Assign 
→Select left line of the Piezo →  Finish or Esc.  
Select Ground → Assign →Select right line of Piezo →  Finish or Esc. 
Click Draw → Colors  
Click Finish or ESC.  
 
ATILA 3.0.27 
 

Click ( )  → Select Electrical Potential → Select Forced → Enter Amplitude 1.0  → Assign 
→Select bottom line of the Piezo →  Finish or Esc.  
Select Ground → Assign →Select Top line of Piezo →  Finish or Esc. 
Click Draw → Colors  
Click Finish or ESC.  
 
See Figure C5.16 for confirmation of electrical potential assignment. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.16. Polarization Confirmation 
 
 



4.3 Displacement 
 
Since we are only using one quarter of the model, when the 2D-axisymmetry is applied only one half of 
the 3D model will be simulated. Thus, it is necessary to apply mirror symmetry to the other half side of 
the quarter model.  
 
ATILA 6.0.0.6 
 
Mirror Symmetry Assignment:  
In ATILA 6.0.0.6, the mirror symmetry is achieved by clamping the X-component of the left-side line of 
the PZT and water, i.e. the line that is on top of the y-axis.  
 

Click ( ) → Select Displacement → Select X Axis Clamped → Select Y Axis None →   Select Z 
Axis None →  Assign → Select vertical lines →  Finish or Esc.  

 
Clamping axis of 2D-Axisymmetry  
The bottom 2D-axisymmetric line (the X-axis in ATILA 6.0.0.6) of the whole structure (including the 
water) is clamped in the Y & Z-components as this line is a revolution axis without Y nor Z motion.  

Select X Axis None →  Select Y Axis Clamped → Select Z Axis None → Assign → Select 
Horizontal lines →  Finish or Esc. 
Click Draw → Colors  
Click Finish or ESC.  

 
See Figure C5.17. for confirmation of displacement assignment. 
 

 
Figure C5.17. Boundary Conditions in ATILA 6.0.0.7 to account for Mirror Symmetry and for the 2D-

Axisymmetry. 
 
IMPORTANT NOTE: When using 2D Axisymmetry in ATILA 6.0.0.6, the admittance results need to be 
multiplied by a factor of 2π. The reason is that ATILA 6.0.0.6 does not consider the effect of the electric 
field in the 2D axisymmety.  
 
Also, when using Mirror symmetry, the admittance result has to be multiplied by a factor of x 2. 
 
Thus, in our case, using 2D-Axisummetry and Mirror symmetry, the admittance result must be multiplied 
by a factor of 2 x 2π to obtain the equivalent value to the full 3D model.  
 



ATILA 3.0.27 
 
Mirror Symmetry Assignment:  
 
In ATILA 3.0.27, several changes have been introduced to obtain the final values of the admittance 
values without the need of applying any multiplying factor after the simulation is done. 
 
First, the 2D-axisymmetry provides the correct value to the 3D model without the need to multiply 
additionally by the 2π factor. So, it is not necessary to multiply anymore by this factor. 
 
Second, to apply the mirror symmetry, ATILA 3.0.27 uses a different approach. It is not necessary to 
apply clamping conditions to the mirror symmetry axis. On contrary, in ATILA 3.0.27 the symmetry is 
applied through the Problem Data menu.  
 
The Problem Data menu now includes a new tab called "Symmetries" with three options corresponding to 
the tree mirror symmetries possible:  
 

Table C1.1. Symmetry options through in ATILA++ through the Problem Data → Symmetries menu 
Symmetry X ‐‐> Plane of Symmetry YoZ Clamps the Y-axis in the X-direction 
Symmetry Y ‐‐> Plane of Symmetry XoZ Clamps the X-axis in the Y-direction 
Symmetry Z ‐‐> Plane of Symmetry XoY Clamps the Z-axis in the Z-direction 

  
For this example, since the mirror symmetry is in the Y-axis, we will choose: 
Problem Data → Symmetries → Symmetry Y → Displacements and Electric field. 
 

 
Figure C5.18. Selection of Symmetry Y for his specific example in ATILA++. 

 
Clamping axis of 2D-Axisymmetry  
The vertical 2D-axisymmetric line (the Y-axis in ATILA 6.0.0.6) of the whole structure (including the 
water) is clamped in the X & Z-components as this line is a revolution axis without X nor Z motion.  
 
 
 
 



 
Figure C5.19. Boundary Conditions in ATILA ++ to account for the 2D-Axisymmetry. Note that the 

Mirror Symmetry in this case is applied through the Problem Data menu. 
 
4.4 Radiating Boundary 
 

Click ( ) → Select Radiation Boundary → Assign → Select the 3 sections of the Arc →  Finish or 
Esc.  
Click Draw → Colors  
Click Finish or ESC.  
 
See Figure C5.20 for confirmation of radiating boundary assignment. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.20. Radiating Boundary Confirmation. 
 
4.5 Acoustic Center (only required in ATILA ++) 
 
In ATILA 6.0.0.6, the acoustic center is automatically assigned as the center of the Radiating Boundary. 
This works fine if the assigned center corresponds to a point of the structure. If the point does not exist, 
this may lead into calculation errors.  
 
In ATILA ++, the Acoustic Center has to be assigned manually in the center of the radiating boundary. 
This ensure that the acoustic center will be assigned in a point of the structure that exists.  
 



Click ( ) → Select Acoustic Center → Assign → Select Center (lower left corner of the Piezo) → 
Finish or Esc.  
Click Draw → Acoustic Center  
Click Finish or ESC.  
 
See Figure C5.21 for confirmation of Acoustic Center assignment. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Note: ATILA 2.0.2.5.4 assigns the acoustic center 
automatically based on the radiating boundary 
information. So, in ATILA 2.0.2.5.4 there is not 

Acoustic Center boundary condition.  

Figure C5.21. Radiating Boundary Confirmation. 
 
4.5 Summary of the boundary conditions 
 
Click Draw → All Conditions → Include Local Axis. 
Click Finish or ESC.  
 
See Figure C5.22 for confirmation of Polarization assignment.  
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

Figure C5.22. All Conditions Confirmation. 
 



MESHING   
 
5. Structured Mesh (Use Drop Down Menu) 
 
ATILA 2.0.2.5.4 
 
Click Mesh → Structured → Surfaces → Number of Cells → Select All surfaces → ESC. 
Enter 3 → Assign → Select the thickness line of the piezoelectric disc → ESC → ESC 
Enter 6 → Assign → Select the other remaining lines → ESC  
 
 
ATILA 3.027 
 
Click Mesh → Structured → Surfaces → Number of Cells → Select All surfaces → ESC. 
Enter 3 → Assign → Select the thickness line of the piezoelectric disc → ESC → ESC 
Enter 6 → Assign → Select the other remaining lines → ESC  
 
Control + G → Mesh generation panel → OK → View Mesh.  
 
See Figure C5.23 for illustration of Mesh selection. 
 

ATILA 2.0.2.5.4 ATILA 3.0.27 

 
Figure C5.23. Viewing the Resultant Mesh. 

 



CALCULATIONS 
 
6. Harmonic Simulation - 2D Axisymmetric 
 

Click ( ) The problem Data panel appears. 
 
6.1 Problem Data settings in ATILA 6.0.0.7 
 
Select the first tab "Problem Data"  → Printing (0)  → Geometry (2D) → Class (Axisymmetric) → 
Analysis (Harmonic) → Include Losses (  ) →  Compute Stress (  ) → Accept 
 

   
Figure C5.24. Problem Data settings for ATILA 6.0.0.7. 

 
6.2 Problem Data settings in ATILA ++ 
 
Select the first tab "Problem Data" → Printing (0)  → Geometry (2D) → Class (Axisymmetric) → 
Analysis (Harmonic) → Include Losses (  ) →  Write strain (  ) → Write Stress (  ) → Accept 
 
Select the tab: "Symmetries" → Symmetry Y → Displacements and Electric field. This assign the 
displacement symmetry conditions (clamp the Y-axis in the X-direction) and the electric field mirror 
symmetry conditions, i.e. computes the admittance with the right value as of the 3D model.  
 

   
Figure C5.25. Problem Data settings for ATILA ++. 

 



6.3 Select the Interval Data for Harmonic simulation 
 

Click ( ) and the Interval Data panel will appear. 
Select TYPE → Linear Distribution → Enter Min Frequency (20000) → Enter Max Frequency 
(100000) → Enter Number of Frequencies (101) → Accept 
 

Click ( ) Copy Conditions entities from interval 1 → Yes → Created interval number 2 Using this 
→ OK 
Click TYPE → Linear Distribution → Enter Min Frequency (44000) → Enter Max Frequency 
(55000) → Enter Number of Frequencies (51) → Accept 
 
Click Calculate → Calculate the simulation will begin. When the simulation is complete the Process 
Info panel will appear (Fig C5.26). Then, select Post-process. 
 

 
Figure C5.26. Process infor window once Calculation finishes. 

 



RESULTS 
 
6. Post-Process/View Results 
 
6.1 Graphs 

Click ( ) → Admittance/Impedance Magnitude panel appears → Admittance → View Graph. See 
Figure C5.27 and C5.28. 
 

 
Figure C5.27. Admittance Graph obtained in ATILA 2.0.2.5.4 from the 2D-Axisymmetric simulation. 

 

 
Figure C5.28. Admittance Graph obtained in ATILA 3.27 from the 2D-Axisymmetric simulation. 



IMPORTANT NOTE: The admittance values in ATILA 6.0.0.7 have to be multiplied by the factor x2 
for the mirror symmetry and the factor 2π for the axisymmetry.  
 

Admittance Values 
 ATILA 6.0.0.7  ATILA 3.0.27 

20kHz 0.00027116 x 2 x 2π = 0.003407 mhos 20kHz 0.00340843 mhos 
51.2 kHz 0.000920983 x 2 x 2π = 0.011573 mhos 51.7 kHz 0.0121412 mhos 

54.78 kHz 0.000544599 x 2 x 2π = 0.006844 mhos 55.0 kHz 0.00654364 mhos 
64.0 kHz 0.000792653 x 2 x 2π = 0.009961 mhos 64.8 kHz 0.0100881 mhos 
82.4 kHz 0.00117055 x 2 x 2π = 0.01471 mhos 81.6 kHz 0.0142109 mhos 
85.6 kHz 0.000958035 x 2 x 2π = 0.012039 mhos 85.6 kHz 0.0122418 mhos 

 
6.2 Animation (Use Drop Down Menu) 

 
Click  View Results → Harmonic-Real Part →  Select Frequency (i.e. 51700)  
 

Click ( )→ OK. Animation is loaded. 

Click ( )   Set the deformation Magnitude.  

Click ( )   To run the animation.  
Click ( )   To stop the animation. 

Click  ( ) → Pressure → ( )  to see the pressure changes through the cycle .  
 
See the results in Figure C5.29. 
 

ATILA 2.0.2.5.4 (51.2 kHz) ATILA 3.0.27 (51.7 kHz) 



Figure C5.29. Animation  of Pressure. 
 

ATILA 2.0.2.5.4 (20 kHz) ATILA 3.0.27 (20 kHz) 

Figure C5.30. Animation of Pressure at 20 kHz. 
 

6.3 TVR (In ATILA 6.0.0.6 - Oy Orientation; In ATILA ++ - Ox Orientation) 
 

 
Figure C5.30. Admittance Graph obtained in ATILA 2.0.2.5.4 from the 2D-Axisymmetric simulation. 

 



 
Figure C5.31. Admittance Graph obtained in ATILA 2.0.2.5.4 from the 2D-Axisymmetric simulation. 

 
 
6.4 TVR (In ATILA 6.0.0.6 - Ox Orientation; In ATILA ++ - Oy Orientation) 
 

 
Figure C5.30. Admittance Graph obtained in ATILA 2.0.2.5.4 from the 2D-Axisymmetric simulation. 

 



 
Figure C5.31. Admittance Graph obtained in ATILA 2.0.2.5.4 from the 2D-Axisymmetric simulation. 

 
 

6.5 PAT 2D (In ATILA ++) 
 

    
Figure C5.32. PAT 2D in ATILA ++ (x0y direction). 

 
SAVING DATA 
 
Click  Save → Enter Name of Project →  Save.  
Example complete.   


